Подготовка к управлению проектами в 1С:Документооборот

Как подготовить 1С:Документооборот к ведению проектной деятельности?

Чтобы начать управлять проектами в 1С:Документооборот, надо предварительно сделать первоначальные настройки в части ведения проектов.



Настройка программы по проектам

Под Администратором 1С:Документооборот открываем настройки программы.
Устанавливаем флажок "Вести учет по проектам".

Виды проектов

В разделе НСИ открываем Виды проектов.
Заполняем виды проектов, которые ведутся в организации.

Группа доступа "Руководители проектов"

В 1С:Документооборот создавать новые проекты могут только пользователи, входящие в группу доступа "Руководители проектов". При этом права на редактирование карточки проекта будут только у пользователя, указанного в проекте как Руководитель проекта. Поэтому открываем в разделе "Настройка и администрирование" справочник "Группы доступа".
Добавляем в группу доступа "Руководители проектов" на закладке "Участники" всех пользователей или группы пользователей, которые будут ответственными за управление проектами.
Сразу обратим внимание на закладку "Ограничения доступа". Здесь можно настроить права для участников группы доступа по "Организациям" и "Грифам доступа". По умолчанию, установлены значения "Все разрешены".

Папки проектов

Открываем список проектов в разделе "Совместная работа".
Создаем структуру папок проектов.
На каждую папку назначаем ответственного за папку.
И назначаем права доступа на папку проектов всем пользователям на чтение, а администрации на редактирование.

Дополнительные реквизиты проектных задач

Можно использовать свои дополнительные реквизиты как для проектов, так и для проектных задач.
Откроем в разделе "Настройка и администрирование" ссылку "Наборы дополнительных реквизитов и сведений".
Можно задавать дополнительные свойства для проектов и для проектных задач для всех элементов или только для конкретных видов.
Добавим новый дополнительный реквизит для проектной задачи определенного вида.
Указываем название дополнительного свойства и тип значения.
Теперь в каждой проектной задаче можно дополнительно указывать, к какому модулю она относится.

Нумератор по проектным документам

Чтобы проектные документы имели свою нумерацию в разрезе каждого проекта, настроим нумератор для всех проектных документов.
В 1С:Документооборот открываем в разделе НСИ справочник "Нумераторы".
Создаем новый нумератор для проектных документов.
Указываем название нумератора и периодичность. На закладке "Формат номера" можем использовать индекс проекта в номере документов.
На закладке "Независимая нумерация" указываем, что документы нужно нумеровать независимо по проекту.
На закладке "Действует для" указываем виды проектных документов.

Подготовка 1С:Документооборот к ведению проектов завершена.

Для того, чтобы узнать больше о проектном управлении в 1С:Документооборот, можно пройти обучение на курсах по 1С:Документооборот.

7 комментариев:

  1. подскажите, пожалуйста, как настроить чтобы при согласовании документа, который относится к конкретному проекту при выборе роли руководителя проекта система определяла кто руководитель у данного проекта и адресовала процесс согласования не всем пользователям с ролью руководитель проекта, а только одному единственному.

    ОтветитьУдалить
    Ответы
    1. Надо сделать новую автоподстановку Руководитель проекта. Вот скрипт для этой автоподстановки:
      Функция РуководительПроекта(БизнесПроцессОбъект, ИмяПредмета) Экспорт
      СтрокаПредмета = БизнесПроцессОбъект.Предметы.Найти(ИмяПредмета, "ИмяПредмета");
      Если СтрокаПредмета <> Неопределено Тогда
      Если Не ЗначениеЗаполнено(СтрокаПредмета.Предмет) Тогда
      ВызватьИсключение СтроковыеФункцииКлиентСервер.ПодставитьПараметрыВСтроку(
      НСтр("ru = 'Автоподстановка не может быть выполнена, так как не указан предмет ""%1"" процесса.'"),
      Строка(ИмяПредмета));
      КонецЕсли;

      Если ТипЗнч(СтрокаПредмета.Предмет) <> Тип("СправочникСсылка.ИсходящиеДокументы") И
      ТипЗнч(СтрокаПредмета.Предмет) <> Тип("СправочникСсылка.ВходящиеДокументы") И
      ТипЗнч(СтрокаПредмета.Предмет) <> Тип("СправочникСсылка.ВнутренниеДокументы") Тогда
      ВызватьИсключение СтроковыеФункцииКлиентСервер.ПодставитьПараметрыВСтроку(
      НСтр("ru = 'Автоподстановка не может быть выполнена для предмета ""%1"" процесса.'"),
      Строка(ИмяПредмета));
      КонецЕсли;

      Возврат ОбщегоНазначения.ЗначениеРеквизитаОбъекта(СтрокаПредмета.Предмет.Проект, "Руководитель");

      Иначе

      ВызватьИсключение СтроковыеФункцииКлиентСервер.ПодставитьПараметрыВСтроку(
      НСтр("ru = 'Не найден предмет ""%1"" процесса.'"),
      Строка(ИмяПредмета));

      КонецЕсли;
      КонецФункции

      В эмуляторе скриптов проверьте как этот скрипт работает:)

      Удалить
  2. Добрый день! Подскажите, пожалуйста, позволяет ли система отправлять проектные задачи автоматически, без создания процессов по каждой проектной задаче плана.

    ОтветитьУдалить
    Ответы
    1. Не позволяет. Надо вручную отправлять процессы по каждой проектной задаче. Но Вы можете сразу их отправить с отложенным стартом.

      Удалить
  3. Добрый день! Ответьте, пожалуйста, на вопрос: можно ли вывести печатную форму Плана проекта, например, Диаграмму Ганта (возможность выгрузить в файл Excel или в формат для чтения: PDF, JPG)?

    ОтветитьУдалить
    Ответы
    1. Нет нельзя.
      Только сделать принтскрин и сохранить в jpg.

      Удалить
  4. Спасибо за ответ!

    ОтветитьУдалить